完整PCQ智能限速脚本带注释

By | 06月23日
Advertisement

完整PCQ智能限速脚本带注释

文章摘要:完整PCQ智能限速脚本,让你的限速更智能化。

  • :for aaa from 1 to 254 do={/queue simple add name=(PC . $aaa) dst-address=(192.168.0. . $aaa) limit-at=500000/500000 max-limit=3000000/3000000}
  • / ip firewall mangle
    add chain=prerouting action=mark-packet new-packet-mark=all-mark passthrough=yes comment="" disabled=no
  • / queue type
    add name="PCQ-up" kind=pcq pcq-rate=1500000 pcq-limit=50 pcq-classifier=src-address pcq-total-limit=2000
    add name="PCQ-down" kind=pcq pcq-rate=1500000 pcq-limit=50 pcq-classifier=dst-address pcq-total-limit=2000
  • / queue simple
    add name="PCQ" target-addresses=192.168.0.0/24 dst-address=0.0.0.0/0 interface=all parent=none packet-marks=all-mark direction=both priority=1 queue=PCQ-up/PCQ-down limit-at=0/0 max-limit=15000000/15000000 total-queue=default-small disabled=yes
  • / system script

    ;最实用的电脑信息技术

    add name="PCQON" source=":if \(\[ /queue sim get \[/queue sim find name=\"PCQ\"\] disable \]=true \) do={/queue sim enable PCQ}" policy=ftp,reboot,read,write,policy,test,winbox,password
    add name="PCQOFF" source=":if \(\[ /queue sim get \[/queue sim find name=\"PCQ\"\] disable \]=false \) do={/queue sim disable PCQ}" policy=ftp,reboot,read,write,policy,test,winbox,password

  • / tool traffic-monitor
    add name="PCQON" interface=WAN traffic=received trigger=above threshold=14800000 on-event=PCQON comment="" disabled=no
    add name="PCQOFF" interface=WAN traffic=received trigger=below threshold=5000000 on-event=PCQOFF comment="" disabled=no
  • =============================================================
  • 上面是完整脚本,直接把每一段复制进去就可以了。需要修改的看下面的说明!
  • 下面是注释
  • ;内容来自www.Gxmmc.com
  • 15M带宽为例 静态是3M,达到14.8M后启用动态是1.5M!
  • :for aaa from 1 to 254 do={/queue simple add name=(PC . $aaa) dst-address=(192.168.0. . $aaa) limit-at=500000/500000 max-limit=3000000/3000000}
  • 这个是建立静态限速,1to254 改为你内网的IP!比如 2 to 120! 192.168.0. 这里改为你的IP段! limit-at=500000/500000 是平均网速500K,max-limit=3000000/3000000 是普通限速3M!
  • 注意一下,在这里我抖正一下,ROS不是1KB=8Kbit! 而是 1000=1K 1000000=1M
  • / ip firewall mangle
    add chain=prerouting action=mark-packet new-packet-mark=all-mark passthrough=yes comment="" disabled=no
  • 这个是固定脚本!
  • / queue type
    add name="PCQ-up" kind=pcq pcq-rate=1500000 pcq-limit=50 pcq-classifier=src-address pcq-total-limit=2000

    ;本文来广西电脑技术专题站

    add name="PCQ-down" kind=pcq pcq-rate=1500000 pcq-limit=50 pcq-classifier=dst-address pcq-total-limit=2000

  • 这里把1500000改为你动态限速时的全网上传速度和下载速度!其他不要改!这里是1.5M!
  • / queue simple
    add name="PCQ" target-addresses=192.168.0.0/24 dst-address=0.0.0.0/0 interface=all parent=none packet-marks=all-mark direction=both priority=1 queue=PCQ-up/PCQ-down limit-at=0/0 max-limit=15000000/15000000 total-queue=default-small disabled=yes
  • 到这里就是建立动态限速的策略了!192.168.0.0/24 改为你IP段!max-limit=15000000/15000000 这里是你总宽带,电信给你多少就填多少!其他不用改,,因为需要转跳到上面的!
  • / system script
    add name="PCQON" source=":if \(\[ /queue sim get \[/queue sim find name=\"PCQ\"\] disable \]=true \) do={/queue sim enable PCQ}" policy=ftp,reboot,read,write,policy,test,winbox,password ;本文来广西电脑技术专题站
    add name="PCQOFF" source=":if \(\[ /queue sim get \[/queue sim find name=\"PCQ\"\] disable \]=false \) do={/queue sim disable PCQ}" policy=ftp,reboot,read,write,policy,test,winbox,password
  • 这个是启发脚本,就是启发动态和关闭动态的脚本!直接复制!
  • / tool traffic-monitor
    add name="PCQON" interface=WAN traffic=received trigger=above threshold=14800000 on-event=PCQON comment="" disabled=no
    add name="PCQOFF" interface=WAN traffic=received trigger=below threshold=5000000 on-event=PCQOFF comment="" disabled=no
  • 这个是流量监控,我有15M设置是14.8M启发,足够了。不会延时或者怎么的,不建议改得太少。threshold=5000000是少于5M时关闭动态!这个自己掌握好!多试试!
  • 另外注意的是!interface=WAN 把WAN改成你外网的网卡!
  • 上面的每一段都需要,少一段这个脚本就不完整!不然没效果不要说我! ;最实用的电脑信息技术

    关于时间段来启发脚本我发出来了,,只需要改最后一段就OK了!

  • =============================================================
  • /system scheduler add name=timeon interval=24h start-time=08:00:00 on-event={PCQON} disabled=no
  • /system scheduler add name=timeoff interval=24h start-time=23:59:59 on-event={PCQOFF} disabled=no
  • ==============================================================
  • 把最后一段替换成这段就是由时间段控制开关PCQ了!

Similar Posts:

  • linux网关上TC给内网做限速脚本

    linux网关上TC给内网做限速脚本 #!/bin/bash ##给192.168.13网段的IP做限速 ##外网网卡 IN=eth1 ##内网网卡 DEV=eth0 start() { ## 清除 eth1 eth0 所有队列规则 tc qdisc del dev $DEV root 2>/dev/null tc qdisc del dev $IN root 2>/dev/null ##定义总的上下带宽 tc qdisc add dev $DEV root handle 2: htb tc

  • [记录]mysql添加列带注释

    1.表结构语句 CREATE TABLE `directory` ( `id` varchar(50) NOT NULL COMMENT '书页ID', `novel_id` varchar(50) default NULL COMMENT '小说ID', `site_id` varchar(50) default NULL COMMENT '站点ID', `dir_url` varchar(256) default NULL COMMENT '书页链接', PRIMARY KEY (`id`)

  • hibernate-tools 生成实体带注释与基础dao,service

    修改hibernate-tools源码,可以生成实体带注释与基础的dao,service 详细见:Evernote

  • 技术扫盲区:Linux 启动脚本 完全注释

    一:背景介绍 Linux太伟大了,什么东西都可以由你来做主,Linux加载完内核后,所有的其他系统服务,进程,都是靠脚本来加载的.所以Linux是这么的透明,你可以清除的指导你的系统做了什么. 下面我就对Linux的启动脚本做了注释,该脚本是属于LFS的,因为该系统比较小,所以可以很清楚的看清楚框架.其他的发行版本的脚本,肯定也会有所不同,但是大框架还是差不多的. 首先对整体流程,叙述一遍.要想了解整体流程,看 /etc/inittab 就可以了,启动过程全是依赖于该配置文件. 1 由引导程序(

  • (转)VS2005宏脚本添加注释模板

    VS2005宏脚本添加注释模板 September 20th, 2008 | lonkil | Visual C++, 本站原创 | 发表评论 | trackback 现 在的IDE越做越强大,为我等懒人省了不少.为了使用将来的代码自己或别人能看懂,注释这种东西必不可少.当为函数添加注释时,格式是固定的.每个函数写 一遍,或从别的函数处拷贝过来,即麻烦又容易出错.这种重复劳动让人心烦都有不想写注释的欲望了,这时VS的宏可以干掉这些"脏.乱.累"的体力活. 看了一下,VS2005的宏脚本

  • 一个做过得项目得log4j配置示例(带注释)

    一个做过得项目得log4j配置示例(带注释) 2007年01月17日 星期三 下午 04:56 #1 定义了两个输出端 log4j.rootLogger = info,A1,A2,A3 #log4j.rootLogger = A1,A2,A3 #2 定义A1输出到控制器 log4j.appender.A1 = org.apache.log4j.ConsoleAppender #3 定义A1的布局模式为PatternLayout log4j.appender.A1.layout = org.apa

  • ROS2.9.27网吧限速脚本

    下面是网吧使用的限速脚本,用了两年多了,效果不错. 脚本代码内容如下 :for i from 101 to 200 do={/queue simple add name=(mm . $i) target-addresses=(192.168.1. . $i) limit-at=0/0 max-limit=3000000/3000000 burst-limit=10000000/10000000 burst-threshold=8000000/8000000 burst-time=15s/15s}

  • 用ROS2.9.7做PCQ集体限速

    我现在做的是基于 ADSL PPPOE的 ROUTER OS 2.9.7 做的(如果想用这个版本的朋友请QQ我) 但是光纤用户一样适用 我现在开始说说步骤 第一:当然最前提的是你的 ROUTER OS 软件路由器能工作了 NAT共享上网成功 第2步:在所有经过ROUTER OS的数据包+ 上MARK 就像猎人要杀猎物也要先找到目标阿 第3步:在QUEUE菜单里面选择Queue Types 创作PCQ限速的子项 这里就决定了你的限制每个IP多少K的速度(2.9系列可以直接用K单位2.8 的不行)

  • SQLMAP tamper WAF 绕过脚本列表注释

    今天我就给大家出一个sqlmap注入过waf的方法集合网上的文章大多不全或者一篇盖过 正文: sqlmap的[url=]tamper[/url]目录下有41个用于绕过waf的脚本,网上有文章简要介绍过使用方法,但是只是简单说了其中少数几个的作用.本人通过这41个脚本的文档注释,将它们每一个的作用简单标记了一下,还是像之前一样,先 google translate 再人工润色.其实,文档注释里面都有例子,看一眼就大概知道效果了,比看文字描述速度还快,只不过要用的时候现场翻看还是太麻烦了.我这个列表

  • 一份智能QOS脚本

    知识点:shell脚本,TC应用,iptables应用 #!/bin/sh #copyright by zhoutao0712 echo -e '\n export UIP="192.168.1."\n export NET="192.168.1.0/24"\n export UP=40\n export DOWN=170\n export UPLOADR=2\n export UPLOADC=12\n export ONLINE=$(cat /proc/net/i

Tags: